Ongoing Power Outage at MA2
Resolved
Dec 10 at 11:34pm EST
We're back up and running!
Affected services
Updated
Dec 10 at 11:28pm EST
Services are slowly returning to operation, we're monitoring until traffic returns to stable numbers.
Affected services
Updated
Dec 10 at 11:15pm EST
Electricity has been restored and we are currently working on bringing all systems back online.
Affected services
Updated
Dec 10 at 10:26pm EST
Crews have been dispatched to resolve the issue, according to Pepco, our electric company.
Affected services
Created
Dec 10 at 10:10pm EST
Jouleworks MidAtlantic #2 is currently experiencing a power outage. Pepco, our utility provider, has determined the cause of the outage to be a transformer failure. Estimated resolution time is no later than 1am Eastern. Updates will be posted here as we get them.
Affected services